Elanthipedia bugs

From elanthipedia
(Redirected from Elanthipedia Bugs)
Jump to: navigation, search

A place to list the current bugs on Elanthipedia itself. For past or fully resolved issues, please see the talk page.


Duplicate Search Results

There seem to be duplicate search results that pop up in the standard search. I've tried deleting some of them, which temporarily works, but they seem to repopulate themselves eventually. -CARAAMON (talk) 08:10, 22 July 2014 (CDT)

Missing Text Editing Buttons

(super low priority, but was handy) - Missing some of the command buttons when on an EDIT screen, like the strikethrough, sub & super text size, etc. that would add the code into your edit form for you--Kythryn

Same issue, but out of these buttons I by far mostly used the "create redirect" button to easily create a redirect page, so I wanted to give special mention to that button to make sure it doesn't get missed in any fix. The button literally just added the text #REDIRECT [[pagename]] to the page, with "pagename" selected as the active text. If any text was selected prior to hitting the button then that text would instead be inside the double brackets.--ABSOLON (talk) 23:28, 30 August 2016 (CDT)
This was most likely part of an extension that did not transfer over. I'll try to track it down, but I can't make any promises. -CARAAMON (talk) 01:47, 31 August 2016 (CDT)
Oh yes, the REDIRECT button would be great to see back...I've mis-typed that word more in the past 24 hours than I thought possible...heh. Also, when editing anything but a TALK page, it looks like the SIGNATURE button has gone the way of the gidii as well. --Kythryn 09:44, 31 August 2016 (CDT)



This seems to have disappeared again. (I was able to use the redirect button not long ago, but now it's gone.) --ISHARON (talk) 17:44, 23 September 2016 (CDT)

Incorrectly Incomplete Marking of All Items

*internal page reference links are acting wonky (see Item:Weathered ilomba chest)
*additionally, looks like tooltips or other similar issues are not populating on the ITEM template display (like the appraisal value conversion, see the ilomba chest for this too)
*and, I just double checked a number of random ITEMS, none are showing any SOURCE links and all of them are tagged for incomplete items
For many items this is unrelated to the wiki update. Items that are marked as incomplete are in many cases just missing tag markers and had the incomplete marking before the update. I did a quick check too and it does appear that some items are getting marked incomplete that shouldn't be. This is likely what is causing the shops to be marked as incomplete as well, since those are marked complete when all the items are completed.--ABSOLON (talk) 16:16, 29 August 2016 (CDT)
I do know there are a number of items/armor/weapons that still have the incomplete tag, and when I do stumble on those, I pop in and update them.
But, I don't think it is some items being marked as incomplete right now, I think it is all of them. I just picked 20 items from the ITEMS category and subcategories (armor, shield, weapons), 20/20 were marked as incomplete, 0/20 had redlinks on the page and 19/20 already had the tags filled out or were MTag=-. When I did update the 1 missing tags, it continued to have the incomplete on save. And, new items being added area also showing as incomplete (ISHARON added this one early this morning Item:Baby shark doll).
That all being said, I wonder if this is tying into the Concept namespace being broken that you mention for the category display below, since the Incomplete Items is italicized on each of these item pages in the Category footer as well. --Kythryn 11:45, 30 August 2016 (CDT)
Okay, I've tracked down sort of why this is happening. At the heart of the code is the line {{#ask:[[{{FULLPAGENAME}}]] [[missing::+]]}} which should check to see if the page has anything in the "missing" property and return the page name if it does, or nothing if it doesn't. However it's always returning the page name, and I have no idea why. -CARAAMON (talk) 17:32, 5 September 2016 (CDT)
The SMW ask query above now always returns a table, so there's always something returned resulting in a match. What you want to use instead is an inline #show query, specifically {{#show: {{FULLPAGENAME}} |?missing}}. This works if you manually save each Item page again now, but is there a way for Admins to clear the Item page cache? Or does this happen automatically? - padhg (talk) 12:57, 15 November 2016 (CST)

Incorrectly Incomplete Shop Pages

Did a spot check on various shops, they all look to be tagged as incomplete articles, even when there are no redlinks on the page

This is very likely related to the bug where all items are being marked as incomplete regardless of whether all of the completion checks are passed or not. I.e. The shop template marks a shop as completed once all the items are marked as completed.--ABSOLON (talk) 23:40, 30 August 2016 (CDT)
This is still being researched. --GAMERGIRL151 (talk) 19:18, 3 September 2016 (CDT)

Properties

It looks like most properties are now functioning with queries and templates, etc. There are still a few oddities with them, however.

  • The actual pages for properties do not exist or are not viewable/editable. E.g. The property [[Spell type is:]] is functioning correctly, but it is not possible to navigate to the property's page within the Property namespace (Property:Spell_type_is) to edit the property's values. This is important, because several properties are designated to require specific values and being unable to edit these means we cannot make adjustments to anything that relies on those properties.
    • Related to this are links that make use of the property within the link do not work right now. These are typically header links in queries, since the links are automatically created by the wiki to link to the property page. E.g. the red links in the headers of each table on Category:Crafting materials
  • Certain properties are still not functioning correctly. The two I can find right now are the properties Property:Has default form , Property:Creature is undead, Property:Creature is evil, and Property:Stealth hindrance is number. In the first three cases, the thing I can find in common is that the properties use compounding values. E.g. "Has default form" always has Form:formname as its value, and the undead and evil properties are compounded into a single property ([[Creature is undead::creature is evil::no]]) since the two properties are so highly related. I am unsure what the issue is for the last one.

--ABSOLON (talk) 23:15, 30 August 2016 (CDT)

Apparently the new version of semantic wiki doesn't like compound semantic annotations (ex. creature is evil::no
"creature is evil::no" is not recognized as a Boolean (true/false) value.
) so I had to split them out into two separate annotations. Unfortunately, it doesn't actually state that anywhere I could find. -CARAAMON (talk) 16:08, 6 September 2016 (CDT)
Looks like 1 of these got missed, the S'Kra Mur still is showing a flag: example on Item:Burnished_electrum_medallion --Kythryn 19:01, 12 November 2016 (CST)
Fixed now, the problem wasn't that it was missed but that it should have been "S'kra Mur style" instead of "S'Kra Mur style". - padhg (talk) 22:53, 1 February 2017 (CST)

Semantic MediaWiki error on title search

Searching for some things (e.g. "Mauler") using the upper-right search box results in an SMW internal error (below). - padhg (talk) 19:25, 7 September 2016 (CDT)

Just adding that this only appears when you search for titles, but happens on all titles. - padhg (talk) 23:05, 18 October 2016 (CDT)
[04fc230d661e04b8d9a140c7] /Mauler MWException from line 640 of /var/www/mediawiki/extensions/SemanticMediaWiki/includes/SemanticData.php: Data for a subobject of Mauler cannot be added to Title:Mauler.

Backtrace:

#0 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/SemanticData.php(326): SMW\SemanticData->addSubSemanticData(SMWContainerSemanticData)
#1 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/parserhooks/AskParserFunction.php(205): SMW\SemanticData->addPropertyObjectValue(SMW\DIProperty, SMWDIContainer)
#2 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/parserhooks/AskParserFunction.php(185): SMW\AskParserFunction->createQueryProfile(SMWQuery, string, integer)
#3 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/parserhooks/AskParserFunction.php(120): SMW\AskParserFunction->doFetchResultsForRawParameters(array)
#4 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/parserhooks/ShowParserFunction.php(67): SMW\AskParserFunction->parse(array)
#5 /var/www/mediawiki/extensions/SemanticMediaWiki/src/ParserFunctionFactory.php(273): SMW\ShowParserFunction->parse(array)
#6 [internal function]: SMW\ParserFunctionFactory->SMW\{closure}(Parser, string, string)
#7 /var/www/mediawiki/includes/parser/Parser.php(3817): call_user_func_array(Closure, array)
#8 /var/www/mediawiki/includes/parser/Parser.php(3552): Parser->callParserFunction(PPTemplateFrame_DOM, string, array)
#9 /var/www/mediawiki/includes/parser/Preprocessor_DOM.php(1175): Parser->braceSubstitution(array, PPTemplateFrame_DOM)
#10 /var/www/mediawiki/includes/parser/Parser.php(3470): PPFrame_DOM->expand(PPNode_DOM)
#11 /var/www/mediawiki/includes/parser/Preprocessor_DOM.php(1175): Parser->braceSubstitution(array, PPTemplateFrame_DOM)
#12 /var/www/mediawiki/includes/parser/Parser.php(3694): PPFrame_DOM->expand(PPNode_DOM)
#13 /var/www/mediawiki/includes/parser/Preprocessor_DOM.php(1175): Parser->braceSubstitution(array, PPFrame_DOM)
#14 /var/www/mediawiki/includes/parser/Parser.php(3366): PPFrame_DOM->expand(PPNode_DOM, integer)
#15 /var/www/mediawiki/includes/parser/Parser.php(1248): Parser->replaceVariables(string)
#16 /var/www/mediawiki/includes/parser/Parser.php(446): Parser->internalParse(string)
#17 /var/www/mediawiki/includes/content/WikitextContent.php(331): Parser->parse(string, Title, ParserOptions, boolean, boolean, integer)
#18 /var/www/mediawiki/includes/content/AbstractContent.php(497): WikitextContent->fillParserOutput(Title, integer, ParserOptions, boolean, ParserOutput)
#19 /var/www/mediawiki/includes/poolcounter/PoolWorkArticleView.php(140): AbstractContent->getParserOutput(Title, integer, ParserOptions)
#20 /var/www/mediawiki/includes/poolcounter/PoolCounterWork.php(123): PoolWorkArticleView->doWork()
#21 /var/www/mediawiki/includes/page/Article.php(666): PoolCounterWork->execute()
#22 /var/www/mediawiki/includes/actions/ViewAction.php(44): Article->view()
#23 /var/www/mediawiki/includes/MediaWiki.php(503): ViewAction->show()
#24 /var/www/mediawiki/includes/MediaWiki.php(288): MediaWiki->performAction(Article, Title)
#25 /var/www/mediawiki/includes/MediaWiki.php(745): MediaWiki->performRequest()
#26 /var/www/mediawiki/includes/MediaWiki.php(519): MediaWiki->main()
#27 /var/www/mediawiki/index.php(43): MediaWiki->run()
#28 {main}

Hindrance on Shields Displaying Incorrectly

This is likely the same issue then, but just documenting the error as I came across it in case it is something else. The HINDRANCE data on the shield page(s) isn't populating correctly: Shield:Gilded harp-shaped buckler inlaid with sparking lightning amethysts --Kythryn 11:45, 30 August 2016 (CDT)

I can't figure out why this property is not functioning correctly, unless perhaps the property didn't get properly re-created. I'm unable to tell, however, due to the other property bug that makes property pages unable to be viewed or edited. FWIW, it also appears to have broken the template, since all shield pages are now automatically being categorized as templates with duplicate arguments despite not having any duplicate arguments.--ABSOLON (talk) 23:36, 30 August 2016 (CDT)
Fixed. -CARAAMON (talk) 16:04, 6 September 2016 (CDT)
This is a slightly different version of this error, but it seems the same as the above duplicate arguments issue. I just ran across this item that is being placed in the "Pages using duplicate arguments in template calls" category: Armor:Heavily_bloodstained_leathers_tooled_with_an_elaborate_symbol_on_the_chest. --Kythryn 19:37, 11 September 2016 (CDT)
Seems to be fixed now. - padhg (talk) 22:43, 1 February 2017 (CST)

Special Properties on weapons

Even when there are no Special Properties (Verbs, Elf Style, Empath Style, etc) selected, the Special Properties line is still showing up on weapons pages. If I remember correctly, this should be hidden when empty. An example of where I saw this was Weapon:Polished_steel_sabre_with_a_jeweled_hilt. --Kythryn 11:08, 5 September 2016 (CDT)

This would be a pain to do properly and it's not a new issue, so I'm going to put it on the backburner for now. -CARAAMON (talk) 16:06, 6 September 2016 (CDT)

Source locations

I believe this might have been an issue before the patch too, but I'm seeing some slightly different weirdness than I remember it being a couple weeks ago. I'll re-create the steps where I saw this issue happen:

1. Take an ITEM page that originally contained additional items (ex. Item:Large red-checked gingham napkin knotted into a makeshift pouch) and the list of those items uses the SLOOT code and that has not been modified since the wiki-patch was rolled in.
2. When you go to one of the additional items (ex. Item:Cup of creamy potato salad topped with slices of hardboiled egg), the Sources line will be showing the shops that the original item came from (ex. for the above would be Fair Faire Fare (3) & 4), however it will not be showing the original item (ie. the napkin)
3. Make any edit to the original item (ie. napkin) and save the page
4. Refresh the additional item page (ie. the potato salad)
5. Now the shops and the original item show up on the Sources line.
Note: the above links have already been "refreshed" so show the full Sources information, I just documented my process with them. To re-create the issue, the Item:Insulated fishtail oak crate nestled within a knotted rope net is similar and *should* produce the same results.

First off, this is a much better situation than before the patch, as those secondary items wouldn't often source the original item at all. But, since this stuff is being worked on, maybe it can be looked into to have the system automatically check for and refresh ITEMS that contain SLOOT in their information, so that we don't have to manually "edit/refresh" those as we come across them? --Kythryn 13:57, 5 September 2016 (CDT)

Have you just tried waiting 1 day and checking back? I could be wrong, but I believe things like this are usually cached on the wiki and updated in batch overnight. The next day the source will look fine. - padhg (talk) 20:36, 5 September 2016 (CDT)
I must have misinterpreted what your suggestion was padhg. I thought you were indicating that the system is currently in the process of refreshing items, and by checking back on ITEMS containing an SLOOT list (such as Item:Insulated fishtail oak crate nestled within a knotted rope net), those SLOOT-linked items would be showing the updated SOURCE information with the original item listed. It has been a number of days though, so maybe you were talking about something else?
Anyhow, to re-cap (TL;DR?) my suggestion:
Summary: The current system now correctly updates the SOURCE on an item if it comes from a "master item" item, not just when from a shop, so long as the "master item" is manually edit/saved. Yey, good stuff!
Possible bug and suggestion for the fix: Can the wiki database be updated so that any ITEM that contains an additional SLOOT in its page information be automatically refreshed, rather than relying on an editor to manual update these ITEMS as they come across them. --Kythryn 15:22, 10 September 2016 (CDT)

Shop "Done" column

This might actually just be working as intended and I don't recognize it because it wasn't working correctly before. However, I just noticed on Fair Faire Fare (3) that further down the shop there are a handful of shop items that have 2 red !! in the DONE column. If these errors are now working as intended, maybe we could get a tooltip for that (and any other) error so editors know what is wrong with that item? --Kythryn 14:34, 5 September 2016 (CDT)

So, a little weirdness that I've never seen before, but I've been using the Item Tester quite a bit today, and just in the past few minutes, I've got the above 2 red !! coming up on a line once the "Show Preview" is used. This is the output:
a silvered bronze ring bearing the crest of the Moon Mage Guild (Item: !!)(Weapon: )(Shield: )(Armor: ) --Kythryn 22:48, 11 September 2016 (CDT)
(Going to add this tangential bug to this because it seems like it might all be 1 issue.)
So on the main HE maps page, with the long shop lists (Hollow Eve Festival 421 map), the items that are showing up on a shop page with the double !! look to be preventing those tables from correctly assigning a Yes to the Items Done column.
For example, the shop Slings and Things (2) is completely populated with all items having blue links, and on the map page, it correctly displays as Yes in the last column.
By contrast, the shop Odiferous Ornaments also is completely populated, and all items also have all blue links, however a few of them also have the !! in the Done column. I took a look at the ones that have errors, and at first thought maybe because they do not have appraisal and measurements, it was causing the !!'s. However a random sample of other clothing items from this shop show that they also don't have those 2 fields filled out but that they are not presenting the !! Done column error.
I then made the leap that it was those incomplete fields from the Odiferous Ornaments items that were causing the Items Done issue, and to confirm that, I went back to the Slings and Things (2) shop list and did a random check of items from that shop (expecting to find no missing field data on any of the items). While a fair number of those slings and weapons are complete, there are also slings that do not have measurements or appraisals filled out. However, those aren't causing any !! errors on the shop Done column and as mentioned, the shop is populating the correct Yes flag on the festival list, so either the weapons template is more forgiving towards shop "completion" than the item template, or the wiki-Gremlins are causing an issue randomly...:)
Anyhow, just trying to document weirdness about this in the hopes that a pattern will emerge for the wiki bug-chasers and this can get squished. --Kythryn 06:20, 8 November 2016 (CST)

USES error on items

When there is an ITEM that has multiple values in USES (ex. Item:Copperleaf_tobacco) it's returning an error. --Kythryn 19:11, 11 September 2016 (CDT)

Use + to separate the numbers. This is to prevent the system from thinking 2,100 is 2 and 100. -CARAAMON (talk) 20:47, 11 September 2016 (CDT)
We're going to need to manually update a number of these then. While I've seen some with the +, I've seen just as many with the , unfortunately. Meh! --Kythryn 21:01, 11 September 2016 (CDT)

Pages using duplicate arguments in template

Today I made a few pages that are making this pop up. There's a whole category for it (Category:Pages using duplicate arguments in template calls). No idea why. -TEVESHSZAT (talk) 22:52, 16 September 2016 (CDT)

Editor role unable to Delete pages

The first Drathrok's Duskruin fell in-between years 418 and 419. I moved all pages to 419, but I'm unable to delete the page Duskruin Auction 418 that needn't exist now. - padhg (talk) 10:30, 20 September 2016 (CDT)

Until it is possible to again delete pages, I'm tagging them with {{DeletePage}}. An admin will need to go in and purge these. - padhg (talk) 13:10, 15 November 2016 (CST)

Broken links under "Contributing" Section on Main Page

Probably aware, but "Red links" page under Large Projects page and "Most Wanted" pages appear to be broken (or at least returning results I don't understand :) ). - STEFYNX (talk)

Projects page is working fine for me but wanted pages is giving a database error. Could you give more details about what is happening on the projects page? --TEVESHSZAT (talk) 09:56, 24 October 2016 (CDT)
It actually appears to be the same page as the other one with the database error. Under Projects, we have a "Stubs, incomplete links, and redlinks" section. There is a "list of redlinks" link there that looks like it might be directing to wanted pages as well. Not sure though, sorry. --STEFYNX (talk)

Database errors with Akigwe's Legacy items

The following pages from Akigwe's Legacy: Secrets of the Tower are all throwing database errors and not loading… --SYDNEE (talk) 22:31, 24 October 2016 (CDT)

https://elanthipedia.play.net/Weapon:Polished_steel_rapier_with_a_large_emerald_pommel
https://elanthipedia.play.net/Shield:Brushed_silver_tower_shield_etched_with_the_image_of_a_towering_keep
https://elanthipedia.play.net/Item:Rugged_leather_thigh_pouch_branded_with_a_detailed_crest
https://elanthipedia.play.net/Item:Steel_drive_shaft_with_an_octagonal_cross-section
https://elanthipedia.play.net/Item:Round_brass_gauge_with_a_series_of_engraved_numbers_around_the_edge
https://elanthipedia.play.net/Item:Round_steel_gauge_with_a_series_of_engraved_marks_along_the_top_edge
https://elanthipedia.play.net/Item:Rectangular_piece_of_thick_glass
https://elanthipedia.play.net/Armor:Variegated_greaves
https://elanthipedia.play.net/Weapon:Metal_yoyo_with_a_pair_of_cambrinth_stones_embedded_on_each_side
https://elanthipedia.play.net/Armor:Dwarven_mining_helm_(2)
https://elanthipedia.play.net/Armor:Worn_dark_leather_siege_gloves_wrapped_in_thick_cobwebs
https://elanthipedia.play.net/Armor:Dwarven_mining_helmet
https://elanthipedia.play.net/Armor:Plate_gauntlets_enameled_on_the_backs_with_a_pearl_grey_tower_being_hit_by_a_bright_white_lightning_bolt
https://elanthipedia.play.net/Armor:Misshapen_bone_breastplate_with_pitted_grooves
https://elanthipedia.play.net/Armor:Worn_dark_leather_siege_coat_covered_in_thick_cobwebs
https://elanthipedia.play.net/Armor:Full_plate_enameled_with_a_pearl_grey_tower_being_hit_by_a_bright_white_lightning_bolt
https://elanthipedia.play.net/Armor:Misshapen_bone_mask
https://elanthipedia.play.net/Armor:Variegated_helm
https://elanthipedia.play.net/Armor:Worn_dark_leather_siege_mask_covered_in_thick_cobwebs
https://elanthipedia.play.net/Item:Pale_blue_talisman_case_embroidered_with_an_owl
https://elanthipedia.play.net/Armor:Great_helm_enameled_with_a_pearl_grey_tower_being_hit_by_a_bright_white_lightning_bolt
https://elanthipedia.play.net/Shield:Darkened_leather_siege_shield
https://elanthipedia.play.net/Shield:Soot_stained_variegated_buckler
https://elanthipedia.play.net/Item:Pale_blue_talisman_case_embroidered_with_a_leopard
https://elanthipedia.play.net/Shield:Metal_war_shield_enameled_with_a_pearl_grey_tower_being_hit_by_a_bright_white_lightning_bolt
https://elanthipedia.play.net/Item:Mahogany_earring_shaped_like_a_tiny_bookshelf
https://elanthipedia.play.net/Item:Snow-white_hiro_bearskin_with_gold-flecked_bloodstone_eyes
https://elanthipedia.play.net/Armor:Suit_of_purple-trimmed_armor_encrusted_with_amethysts
https://elanthipedia.play.net/Item:Striated_cambrinth_armband_inset_with_dozens_of_tiny_sparkling_gems
There are also at least 2 items from the Blood and Gourd game prizes that look to have the same/similar database errors:
I can go and check through more of that loot table if needed to see if there are others, just stumbled over these 2 when I was verifying item completion and remembered the similar BUG note from this page. --Kythryn 06:43, 3 November 2016 (CDT)
I fixed these like a few others, and I think I know what is causing it to happen. Any item, mostly old items, where the item has brackets around the location name (aka: shop name), is causing those pages to bug out. If you manually enter the URL that lets you edit that page and remove that part of the code, it fixes itself. If you don't, it stays broken. --TEVESHSZAT (talk) 21:17, 3 November 2016 (CDT)
So this: "If you manually enter the URL that lets you edit that page...", how do you do that? I've been coming across these pages and instead of just ignoring them, I'll help update them if I can. Thanks! --Kythryn 15:46, 12 November 2016 (CST)
Sorry I missed people commenting on this.. I went back and fixed the rest of the above items I posted and a few others I came across as well. Kythryn, as to how to manually edit the page to fix these it means you need to type in the correct URL to directly take you to the edit form page for said item. So to say fix the "Darkened leather siege shield" you would take the form edit URL "https://elanthipedia.play.net/index.php?title=XXX&action=formedit" and the full item name/title "Shield:Darkened_leather_siege_shield" and put that where the XXX is in the form edit URL, as such... "https://elanthipedia.play.net/index.php?title=Shield:Darkened_leather_siege_shield&action=formedit". That takes you directly to the edit form for that item. --SYDNEE (talk) 16:33, 12 November 2016 (CST)
Great, thank you! I'll make a note of this and update as I come across them. --Kythryn 19:02, 12 November 2016 (CST)

Webserver error on save/preview pages with more than 3 sections

Trying to save/preview any page with more than 3 sections at a time (where the TOC would usually show) currently results in a Nginx 500 Internal Server Error. I can workaround this by editing a single section at a time, but it makes updates to things like the Category:Crafting materials page painful where I want to update all of the #ask queries to return a format=broadtable. - padhg (talk) 10:13, 18 November 2016 (CST)

This seems to be working again, hoping onsite support may have resolved the issue? - padhg (talk) 11:11, 18 November 2016 (CST)
Still keeps getting 502 errors when updating something too "big" on my end. Search function looks all wonky, too. -TEVESHSZAT (talk) 13:53, 19 November 2016 (CST)

database error on Item:Sprig_of_rue

MOTHRA (talk) 22:23, 1 February 2017 (CST)

I manually went to the /index.php?title=Item:Sprig_of_rue&action=edit page. Going there showed me the below. By removing the type2, cost3, and sourcetype3 attributes everything seems to be working. My best guess is the ilink for the source was causing the issue. This is fixed now. - padhg (talk) 22:40, 1 February 2017 (CST)
{{Item |noun=rue |look=You see nothing unusual. |MTag=- |type=cleric style |type2=quest |weight=5 |appcost=0 |source=part of the [[Commune#Glythtide's Commune|Glythtide's Commune]] |cost=0 |sourcetype=other |source3={{ilink|i|tansy tart}} |cost3=0 |sourcetype3=other |fname=No }} Used in the creation of a {{ilink|i|Be'ort tear rose}}. {{cat|Flowers,Quest flowers}}