Elanthipedia bugs

From elanthipedia
Revision as of 11:08, 5 September 2016 by ZUERCAT (talk | contribs)

Jump to: navigation, search

A place to list the current bugs on Elanthipedia itself. For past or fully resolved issues, please see the talk page.


Duplicate Search Results

There seem to be duplicate search results that pop up in the standard search. I've tried deleting some of them, which temporarily works, but they seem to repopulate themselves eventually. -CARAAMON (talk) 08:10, 22 July 2014 (CDT)

Sandbox Page Missing

... I sure hope the personal sandbox pages get restored. Stupid technology moving forward...:P --Kythryn 09:39, 24 August 2016 (CDT)

Your sandbox, favorites, notes, etc should still be there, it's just the easy links to them that are missing from the header links. Just add it to the end of your user account page and you can manually travel there. E.g. https://elanthipedia.play.net/User:ZUERCAT/Sandbox--ABSOLON (talk) 15:42, 24 August 2016 (CDT)
*personal sandbox link missing (top right was where it was, by the preferences link) - thanks ABSOLON! Glad it didn't get scrubbed. Be nice to have those links back though if there's a way, not sure new wiki users would even know they are available
It's part of an extension called AddPersonalUrls, something I'll ask onsite to add back in once we have the major problems stamped out. -CARAAMON (talk) 01:33, 31 August 2016 (CDT)
Sandbox page links should be restored. The links however are showing in red at this time, giving it the appearance that there may be nothing there. --GAMERGIRL151 (talk) 19:18, 3 September 2016 (CDT)

Missing Text Editing Buttons

(super low priority, but was handy) - Missing some of the command buttons when on an EDIT screen, like the strikethrough, sub & super text size, etc. that would add the code into your edit form for you--Kythryn

Same issue, but out of these buttons I by far mostly used the "create redirect" button to easily create a redirect page, so I wanted to give special mention to that button to make sure it doesn't get missed in any fix. The button literally just added the text #REDIRECT [[pagename]] to the page, with "pagename" selected as the active text. If any text was selected prior to hitting the button then that text would instead be inside the double brackets.--ABSOLON (talk) 23:28, 30 August 2016 (CDT)
This was most likely part of an extension that did not transfer over. I'll try to track it down, but I can't make any promises. -CARAAMON (talk) 01:47, 31 August 2016 (CDT)
Oh yes, the REDIRECT button would be great to see back...I've mis-typed that word more in the past 24 hours than I thought possible...heh. Also, when editing anything but a TALK page, it looks like the SIGNATURE button has gone the way of the gidii as well. --Kythryn 09:44, 31 August 2016 (CDT)

Incorrectly Incomplete Marking of All Items

*internal page reference links are acting wonky (see Item:Weathered ilomba chest)
*additionally, looks like tooltips or other similar issues are not populating on the ITEM template display (like the appraisal value conversion, see the ilomba chest for this too)
*and, I just double checked a number of random ITEMS, none are showing any SOURCE links and all of them are tagged for incomplete items
For many items this is unrelated to the wiki update. Items that are marked as incomplete are in many cases just missing tag markers and had the incomplete marking before the update. I did a quick check too and it does appear that some items are getting marked incomplete that shouldn't be. This is likely what is causing the shops to be marked as incomplete as well, since those are marked complete when all the items are completed.--ABSOLON (talk) 16:16, 29 August 2016 (CDT)
I do know there are a number of items/armor/weapons that still have the incomplete tag, and when I do stumble on those, I pop in and update them.
But, I don't think it is some items being marked as incomplete right now, I think it is all of them. I just picked 20 items from the ITEMS category and subcategories (armor, shield, weapons), 20/20 were marked as incomplete, 0/20 had redlinks on the page and 19/20 already had the tags filled out or were MTag=-. When I did update the 1 missing tags, it continued to have the incomplete on save. And, new items being added area also showing as incomplete (ISHARON added this one early this morning Item:Baby shark doll).
That all being said, I wonder if this is tying into the Concept namespace being broken that you mention for the category display below, since the Incomplete Items is italicized on each of these item pages in the Category footer as well. --Kythryn 11:45, 30 August 2016 (CDT)

Incorrectly Incomplete Shop Pages

Did a spot check on various shops, they all look to be tagged as incomplete articles, even when there are no redlinks on the page

This is very likely related to the bug where all items are being marked as incomplete regardless of whether all of the completion checks are passed or not. I.e. The shop template marks a shop as completed once all the items are marked as completed.--ABSOLON (talk) 23:40, 30 August 2016 (CDT)
This is still being researched. --GAMERGIRL151 (talk) 19:18, 3 September 2016 (CDT)

Properties

It looks like most properties are now functioning with queries and templates, etc. There are still a few oddities with them, however.

  • The actual pages for properties do not exist or are not viewable/editable. E.g. The property [[Spell type is:]] is functioning correctly, but it is not possible to navigate to the property's page within the Property namespace (Property:Spell_type_is) to edit the property's values. This is important, because several properties are designated to require specific values and being unable to edit these means we cannot make adjustments to anything that relies on those properties.
    • Related to this are links that make use of the property within the link do not work right now. These are typically header links in queries, since the links are automatically created by the wiki to link to the property page. E.g. the red links in the headers of each table on Category:Crafting materials
  • Certain properties are still not functioning correctly. The two I can find right now are the properties Property:Has default form , Property:Creature is undead, Property:Creature is evil, and Property:Stealth hindrance is number. In the first three cases, the thing I can find in common is that the properties use compounding values. E.g. "Has default form" always has Form:formname as its value, and the undead and evil properties are compounded into a single property ([[Creature is undead::creature is evil::no]]) since the two properties are so highly related. I am unsure what the issue is for the last one.

--ABSOLON (talk) 23:15, 30 August 2016 (CDT)

Hindrance on Shields Displaying Incorrectly

This is likely the same issue then, but just documenting the error as I came across it in case it is something else. The HINDRANCE data on the shield page(s) isn't populating correctly: Shield:Gilded harp-shaped buckler inlaid with sparking lightning amethysts --Kythryn 11:45, 30 August 2016 (CDT)

I can't figure out why this property is not functioning correctly, unless perhaps the property didn't get properly re-created. I'm unable to tell, however, due to the other property bug that makes property pages unable to be viewed or edited. FWIW, it also appears to have broken the template, since all shield pages are now automatically being categorized as templates with duplicate arguments despite not having any duplicate arguments.--ABSOLON (talk) 23:36, 30 August 2016 (CDT)

Show properties link

The "Browse properties" link in the side-bar is not always appearing on pages that should have it.
(Possibly related to this is that the link (previously called "Show properties") used to show up twice in most cases, so it may simply be an extension of that bug but exhibiting in a different way. E.g. A single copy was removed from all pages, changing it from either 2 or 1 links on each page to 1 or 0 on each page.) --ABSOLON (talk) 23:15, 30 August 2016 (CDT)

Here is an example page where the link does not show up: Shield:Gilded_harp-shaped_buckler_inlaid_with_sparking_lightning_amethysts
This is possibly related to the above issue with the shield hindrance value not displaying properly.--ABSOLON (talk) 23:36, 30 August 2016 (CDT)
I think it's related to the fact that semantics are disabled for Item, Weapon, Armor, and Post namespaces. This is something that needs fixing. -CARAAMON (talk) 01:35, 31 August 2016 (CDT)

Missing page views

The counter in the page footer of every page that showed the number of views that page had is missing.--ABSOLON (talk) 00:06, 31 August 2016 (CDT)

It looks like this functionality was just outright removed in newer versions of Wikimedia. Since the data is gone and it would require a new extension to be added to regain that functionality, I'm inclined to let it die. -CARAAMON (talk) 01:55, 31 August 2016 (CDT)

Special Properties on weapons

Even when there are no Special Properties (Verbs, Elf Style, Empath Style, etc) selected, the Special Properties line is still showing up on weapons pages. If I remember correctly, this should be hidden when empty. An example of where I saw this was Weapon:Polished_steel_sabre_with_a_jeweled_hilt. --Kythryn 11:08, 5 September 2016 (CDT)