Difference between revisions of "Elanthipedia bugs"

From elanthipedia
Jump to: navigation, search
(Page creation)
(Unable to Dismiss Site Notice)
Line 28: Line 28:
  
 
==Unable to Dismiss Site Notice==
 
==Unable to Dismiss Site Notice==
*there is no link to dismiss the <s>"ATTENTION Semantic searching and tagging for Armor, Weapon, Shield, and Post categories are not functioning properly. It is being worked on."</s> notice at the top of the page
+
<s>*there is no link to dismiss the "ATTENTION Semantic searching and tagging for Armor, Weapon, Shield, and Post categories are not functioning properly. It is being worked on." notice at the top of the page
: It's part of an extension called DismissableSiteNotice, something I'll ask onsite to add back in once we have the major problems stamped out. -[[User:CARAAMON|CARAAMON]] ([[User talk:CARAAMON|talk]]) 01:34, 31 August 2016 (CDT)
+
: It's part of an extension called DismissableSiteNotice, something I'll ask onsite to add back in once we have the major problems stamped out. -[[User:CARAAMON|CARAAMON]] ([[User talk:CARAAMON|talk]]) 01:34, 31 August 2016 (CDT)</s>
 +
:: Fixed, thanks!  --[[Kythryn]] 18:31, 3 September 2016 (CDT)
  
 
==Ranik Map Index Formatting==
 
==Ranik Map Index Formatting==

Revision as of 18:31, 3 September 2016

A place to list the current bugs on Elanthipedia itself.


Duplicate Search Results

There seem to be duplicate search results that pop up in the standard search. I've tried deleting some of them, which temporarily works, but they seem to repopulate themselves eventually. -CARAAMON (talk) 08:10, 22 July 2014 (CDT)

Sandbox Page Missing

... I sure hope the personal sandbox pages get restored. Stupid technology moving forward...:P --Kythryn 09:39, 24 August 2016 (CDT)

Your sandbox, favorites, notes, etc should still be there, it's just the easy links to them that are missing from the header links. Just add it to the end of your user account page and you can manually travel there. E.g. https://elanthipedia.play.net/User:ZUERCAT/Sandbox--ABSOLON (talk) 15:42, 24 August 2016 (CDT)
*personal sandbox link missing (top right was where it was, by the preferences link) - thanks ABSOLON! Glad it didn't get scrubbed. Be nice to have those links back though if there's a way, not sure new wiki users would even know they are available
It's part of an extension called AddPersonalUrls, something I'll ask onsite to add back in once we have the major problems stamped out. -CARAAMON (talk) 01:33, 31 August 2016 (CDT)

Missing Text Editing Buttons

(super low priority, but was handy) - Missing some of the command buttons when on an EDIT screen, like the strikethrough, sub & super text size, etc. that would add the code into your edit form for you--Kythryn

Same issue, but out of these buttons I by far mostly used the "create redirect" button to easily create a redirect page, so I wanted to give special mention to that button to make sure it doesn't get missed in any fix. The button literally just added the text #REDIRECT [[pagename]] to the page, with "pagename" selected as the active text. If any text was selected prior to hitting the button then that text would instead be inside the double brackets.--ABSOLON (talk) 23:28, 30 August 2016 (CDT)
This was most likely part of an extension that did not transfer over. I'll try to track it down, but I can't make any promises. -CARAAMON (talk) 01:47, 31 August 2016 (CDT)
Oh yes, the REDIRECT button would be great to see back...I've mis-typed that word more in the past 24 hours than I thought possible...heh. Also, when editing anything but a TALK page, it looks like the SIGNATURE button has gone the way of the gidii as well. --Kythryn 09:44, 31 August 2016 (CDT)

Incorrectly Incomplete Marking of All Items

*internal page reference links are acting wonky (see Item:Weathered ilomba chest)
*additionally, looks like tooltips or other similar issues are not populating on the ITEM template display (like the appraisal value conversion, see the ilomba chest for this too)
*and, I just double checked a number of random ITEMS, none are showing any SOURCE links and all of them are tagged for incomplete items
For many items this is unrelated to the wiki update. Items that are marked as incomplete are in many cases just missing tag markers and had the incomplete marking before the update. I did a quick check too and it does appear that some items are getting marked incomplete that shouldn't be. This is likely what is causing the shops to be marked as incomplete as well, since those are marked complete when all the items are completed.--ABSOLON (talk) 16:16, 29 August 2016 (CDT)
I do know there are a number of items/armor/weapons that still have the incomplete tag, and when I do stumble on those, I pop in and update them.
But, I don't think it is some items being marked as incomplete right now, I think it is all of them. I just picked 20 items from the ITEMS category and subcategories (armor, shield, weapons), 20/20 were marked as incomplete, 0/20 had redlinks on the page and 19/20 already had the tags filled out or were MTag=-. When I did update the 1 missing tags, it continued to have the incomplete on save. And, new items being added area also showing as incomplete (ISHARON added this one early this morning Item:Baby shark doll).
That all being said, I wonder if this is tying into the Concept namespace being broken that you mention for the category display below, since the Incomplete Items is italicized on each of these item pages in the Category footer as well. --Kythryn 11:45, 30 August 2016 (CDT)

Unable to Dismiss Site Notice

*there is no link to dismiss the "ATTENTION Semantic searching and tagging for Armor, Weapon, Shield, and Post categories are not functioning properly. It is being worked on." notice at the top of the page

It's part of an extension called DismissableSiteNotice, something I'll ask onsite to add back in once we have the major problems stamped out. -CARAAMON (talk) 01:34, 31 August 2016 (CDT)
Fixed, thanks! --Kythryn 18:31, 3 September 2016 (CDT)

Ranik Map Index Formatting

Formatting went haywire on the top-level Ranik Maps page

Fixed.--ABSOLON (talk) 05:21, 31 August 2016 (CDT)

Incorrectly Incomplete Shop Pages

Did a spot check on various shops, they all look to be tagged as incomplete articles, even when there are no redlinks on the page

This is very likely related to the bug where all items are being marked as incomplete regardless of whether all of the completion checks are passed or not. I.e. The shop template marks a shop as completed once all the items are marked as completed.--ABSOLON (talk) 23:40, 30 August 2016 (CDT)

Page Movement Errors

Getting the following error when I attempt to MOVE a page (This is the one I was moving News:Dateline 8/8/2012: WELCOME TO DRAGONREALMS):

Error: 1146 Table 'elanthipedia2.smw_fpt_askdu' doesn't exist (wikisql2.simutronics.com)


I get the following error when I attempt to move pages:

A database query error has occurred. This may indicate a bug in the software.
Query:
UPDATE `smw_fpt_askdu` SET s_id = '616505' WHERE s_id = '290888'
Function: SMWSQLStore3::changeSMWPageID
Error: 1146 Table 'elanthipedia2.smw_fpt_askdu' doesn't exist (wikisql2.simutronics.com)
Backtrace:
#0 /var/www/mediawiki/includes/db/Database.php(901): DatabaseBase->reportQueryError('Table 'elanthip...', 1146, 'UPDATE `smw_fp...', 'SMWSQLStore3::c...', false)
#1 /var/www/mediawiki/includes/db/Database.php(1512): DatabaseBase->query('UPDATE `smw_fp...', 'SMWSQLStore3::c...')
#2 /var/www/mediawiki/extensions/SemanticMediaWiki/src/MediaWiki/Database.php(334): DatabaseBase->update('smw_fpt_askdu', Array, Array, 'SMWSQLStore3::c...', Array)
#3 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/storage/SQLStore/SMW_SQLStore3.php(598): SMW\MediaWiki\Database->update('smw_fpt_askdu', Array, Array, 'SMWSQLStore3::c...')
#4 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/storage/SQLStore/SMW_SQLStore3_Writers.php(666): SMWSQLStore3->changeSMWPageID(290888, 616505, 0, 0, true, false)
#5 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/storage/SQLStore/SMW_SQLStore3.php(351): SMWSQLStore3Writers->changeTitle(Object(Title), Object(Title), 114667, 36640)
#6 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/StoreUpdater.php(235): SMWSQLStore3->changeTitle(Object(Title), Object(Title), 114667, 36640)
#7 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/StoreUpdater.php(208): SMW\StoreUpdater->handleYetUnknownRedirectTarget(Object(SMW\SemanticData), Object(SMW\DIWikiPage))
#8 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/StoreUpdater.php(180): SMW\StoreUpdater->checkForRequiredRedirectUpdate(Object(SMW\SemanticData))
#9 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/StoreUpdater.php(125): SMW\StoreUpdater->doRealUpdate(NULL)
#10 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/StoreUpdater.php(92): SMW\StoreUpdater->performUpdate()
#11 /var/www/mediawiki/extensions/SemanticMediaWiki/includes/ParserData.php(261): SMW\StoreUpdater->doUpdate()
#12 /var/www/mediawiki/extensions/SemanticMediaWiki/src/MediaWiki/Hooks/LinksUpdateConstructed.php(62): SMW\ParserData->updateStore()
#13 /var/www/mediawiki/extensions/SemanticMediaWiki/src/MediaWiki/Hooks/HookRegistry.php(287): SMW\MediaWiki\Hooks\LinksUpdateConstructed->process()
#14 [internal function]: SMW\MediaWiki\Hooks\HookRegistry->SMW\MediaWiki\Hooks\{closure}(Object(LinksUpdate))
#15 /var/www/mediawiki/includes/Hooks.php(195): call_user_func_array(Object(Closure), Array)
#16 /var/www/mediawiki/includes/deferred/LinksUpdate.php(139): Hooks::run('LinksUpdateCons...', Array)
#17 /var/www/mediawiki/includes/content/AbstractContent.php(234): LinksUpdate->__construct(Object(Title), Object(ParserOutput), true)
#18 /var/www/mediawiki/includes/page/WikiPage.php(2185): AbstractContent->getSecondaryDataUpdates(Object(Title), NULL, true, Object(ParserOutput))
#19 /var/www/mediawiki/includes/MovePage.php(562): WikiPage->doEditUpdates(Object(Revision), Object(User), Array)
#20 /var/www/mediawiki/includes/MovePage.php(258): MovePage->moveToInternal(Object(User), Object(Title), 'capitalization ...', true)
#21 /var/www/mediawiki/includes/specials/SpecialMovepage.php(591): MovePage->move(Object(User), 'capitalization ...', true)
#22 /var/www/mediawiki/includes/specials/SpecialMovepage.php(128): MovePageForm->doSubmit()
#23 /var/www/mediawiki/includes/specialpage/SpecialPage.php(479): MovePageForm->execute(NULL)
#24 /var/www/mediawiki/includes/specialpage/SpecialPageFactory.php(576): SpecialPage->run(NULL)
#25 /var/www/mediawiki/includes/MediaWiki.php(282): SpecialPageFactory::executePath(Object(Title), Object(RequestContext))
#26 /var/www/mediawiki/includes/MediaWiki.php(745): MediaWiki->performRequest()
#27 /var/www/mediawiki/includes/MediaWiki.php(519): MediaWiki->main()
#28 /var/www/mediawiki/index.php(43): MediaWiki->run()
#29 {main}

Missing Forms

The "Edit with Form" link is missing on item/shield/weapon pages. --Kythryn 11:47, 30 August 2016 (CDT)

Edit with form is missing in all cases. I believe this is tied to property pages, since some of them still seem to be missing or not functioning correctly. Pages within a category (e.g. Category:Spells) are tied to a form via two things:
  1. The output template that is used on the pages that use the form and designated within the form's code to be used to output the form's results.
  2. A property added to a Category page that tells the wiki that pages within this category are to use a designated form.
What appears to be broken here is #2; the property that states that a category should use a given form doesn't exist. See Category:Spells for an example of where the property designator [[has default form::Form:Spell| ]] is not working correctly because the either or both of the Property:Has default form page doesn't exist or isn't functioning correctly. The latter might be that properties that have multiple layers that are not functioning. I.e. The value Form:Spell might not be working properly because it is a compound value.--ABSOLON (talk) 23:02, 30 August 2016 (CDT)
I seem to have been able to jumpstart the automatic usage of forms by simply empty editing the appropriate Elanthipedia namespace pages. Let me know if any are still misbehaving. -CARAAMON (talk) 01:49, 31 August 2016 (CDT)
Spell pages, character pages, creature pages, and NPC pages are still missing. I.e. the ones on the Elanthipedia:Forms list that are in the default Page namespace rather than a custom or wiki one. The form can be accessed using those links, so the form itself is functioning correctly, it's just missing the link at the top of the content page.--ABSOLON (talk) 02:07, 31 August 2016 (CDT)
That should have fixed those. -CARAAMON (talk) 03:02, 31 August 2016 (CDT)

Yes, this appears to be fixed.--ABSOLON (talk) 09:50, 31 August 2016 (CDT)

Properties

It looks like most properties are now functioning with queries and templates, etc. There are still a few oddities with them, however.

  • The actual pages for properties do not exist or are not viewable/editable. E.g. The property [[Spell type is:]] is functioning correctly, but it is not possible to navigate to the property's page within the Property namespace (Property:Spell_type_is) to edit the property's values. This is important, because several properties are designated to require specific values and being unable to edit these means we cannot make adjustments to anything that relies on those properties.
    • Related to this are links that make use of the property within the link do not work right now. These are typically header links in queries, since the links are automatically created by the wiki to link to the property page. E.g. the red links in the headers of each table on Category:Crafting materials
  • Certain properties are still not functioning correctly. The two I can find right now are the properties Property:Has default form , Property:Creature is undead, Property:Creature is evil, and Property:Stealth hindrance is number. In the first three cases, the thing I can find in common is that the properties use compounding values. E.g. "Has default form" always has Form:formname as its value, and the undead and evil properties are compounded into a single property ([[Creature is undead::creature is evil::no]]) since the two properties are so highly related. I am unsure what the issue is for the last one.

--ABSOLON (talk) 23:15, 30 August 2016 (CDT)

Hindrance on Shields Displaying Incorrectly

This is likely the same issue then, but just documenting the error as I came across it in case it is something else. The HINDRANCE data on the shield page(s) isn't populating correctly: Shield:Gilded harp-shaped buckler inlaid with sparking lightning amethysts --Kythryn 11:45, 30 August 2016 (CDT)

I can't figure out why this property is not functioning correctly, unless perhaps the property didn't get properly re-created. I'm unable to tell, however, due to the other property bug that makes property pages unable to be viewed or edited. FWIW, it also appears to have broken the template, since all shield pages are now automatically being categorized as templates with duplicate arguments despite not having any duplicate arguments.--ABSOLON (talk) 23:36, 30 August 2016 (CDT)

Show properties link

The "Browse properties" link in the side-bar is not always appearing on pages that should have it.
(Possibly related to this is that the link (previously called "Show properties") used to show up twice in most cases, so it may simply be an extension of that bug but exhibiting in a different way. E.g. A single copy was removed from all pages, changing it from either 2 or 1 links on each page to 1 or 0 on each page.) --ABSOLON (talk) 23:15, 30 August 2016 (CDT)

Here is an example page where the link does not show up: Shield:Gilded_harp-shaped_buckler_inlaid_with_sparking_lightning_amethysts
This is possibly related to the above issue with the shield hindrance value not displaying properly.--ABSOLON (talk) 23:36, 30 August 2016 (CDT)
I think it's related to the fact that semantics are disabled for Item, Weapon, Armor, and Post namespaces. This is something that needs fixing. -CARAAMON (talk) 01:35, 31 August 2016 (CDT)

Italicized items in category list

These are now working as they were before the update. There are two types of these links:

  • Italicized links in the bulleted list at the bottom of the category page itself. This happens when a category page gets redirected to incorrectly. A lot of these were introduced when we made the big capitalization push, since many category pages were affected. I fix them as I come across them, since there's no real way to search for them. Here's what causes it and how to fix it if you want to do them if you come across them:
A redirect to a Category page should have a colon in front of the 'Category' text. E.g.: #REDIRECT [[:Category:Spell types]]. If it doesn't include the leading colon then the redirect page gets added as an italicized item on the category page it redirects to. In short, the wiki thinks it belongs in the category unless the leading colon is there.
Note that this also applies to links to a category page if the page itself is not supposed to be in the category list. E.g. a users favourites page might have a link to the crafting materials category and the proper syntax would be [[:Category:Crafting materials]] with the leading colon. Without the colon, the person's favourites page would show up as an item in the list at the bottom of the category page. These are rarer, and harder to spot since they're not in italics.
  • Italicized links in the category infobox at the bottom of a non-category page (E.g. a creature's page).
These links are links to concept pages instead of categories, and were italicized before the update. I can look into making the template not italicize them, but for now these are considered "working".

--ABSOLON (talk) 00:02, 31 August 2016 (CDT)

Missing page views

The counter in the page footer of every page that showed the number of views that page had is missing.--ABSOLON (talk) 00:06, 31 August 2016 (CDT)

It looks like this functionality was just outright removed in newer versions of Wikimedia. Since the data is gone and it would require a new extension to be added to regain that functionality, I'm inclined to let it die. -CARAAMON (talk) 01:55, 31 August 2016 (CDT)

References are not parsed

With the latest update, <ref>, </ref>, and <references /> are not treated as wiki tags. See DEPART for an example. - padhg (talk) 11:18, 31 August 2016 (CDT)

Needs the extension Cite enabled for this to work. I'll add it to the list of things to do once the major problems are stamped out. -CARAAMON (talk) 17:45, 31 August 2016 (CDT)

Page creation

When trying to create a new page titled Elanthipedia bugs (as opposed to the current [[Elanthipedia Bugs]] page) in order to handle redirects, etc. it makes me do it using the Form:Player Characters form with the option to instead use the Form:BrawlItem form. This happens when I click on the redlink on this redirect page: Bugs.

This link is what it brings me to (the wiki parses the link incorrectly so you'll need to manually follow it via cut and paste):
https://elanthipedia.play.net/Special:FormEdit/Player%20Characters/Elanthipedia_bugs?alt_form[0]=BrawlItem&redlink=1

--ABSOLON (talk) 22:41, 1 September 2016 (CDT)

Just to add to this issue, it seems to happen with pretty much any redlink (weapon, item, etc). I just had the two item links here try to use the character template, too. -TEVESHSZAT (talk) 23:36, 1 September 2016 (CDT)
Well huh. I'm not seeing a rhyme or reason to when this kicks in. If I had to guess, I'd suspect something's buggy with the Wikimedia core program or it's interaction with semantic forms... but I 'll keep poking it. -CARAAMON (talk) 16:02, 2 September 2016 (CDT)

Linking between pages and their talk pages

When clicking on the "Page" link at the top of a Talk page to view the main page does not always work. You remain on the talk page. E.g. Armor_talk:Ring_lorica_(crafted)
Related to this, before the update when we could still move pages, if you move a Page (which usually moves the talk page along with it) the talk page sometimes doesn't get moved and you end up with weird cross linking between the new main page, the old talk page, and the new talk page.--ABSOLON (talk) 22:41, 1 September 2016 (CDT)

This happens to any discussion page in the Item: or Armor: namespaces. Their Discussion page links are broken. See Template_talk:Item#Discussion_links_for_this_template_are_broken. - padhg (talk) 12:54, 2 September 2016 (CDT)